Support email address experiencing issues
Incident Report for Split
Resolved
This issue has been resolved, and now support cases received through support@split.io are being processed normally.
Posted Nov 29, 2024 - 11:59 PST
Identified
We have identified an issue affecting our ability to process support cases through support@split.io and our team is working on resolving this.

In the meantime, support tickets can be created normally using our support@splitsoftware.zendesk.com address.

Support cases opened through our Help Center or Web console are unaffected.
Posted Nov 29, 2024 - 10:28 PST