Corp site temporarily unreachable
Incident Report for Split
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 28, 2019 - 18:31 PDT
Identified
Our corporate website is partially unreachable. However, our cloud application can still be reached at https://app.split.io
Posted 4 months ago. Jun 28, 2019 - 18:02 PDT
This incident affected: Corporate Site.