Split Help Center Down
Incident Report for Split
Resolved
This incident has been resolved.
Posted Aug 03, 2022 - 12:41 PDT
Investigating
We are currently investigating an issue with the Help Center being offline.
Posted Aug 03, 2022 - 11:50 PDT
This incident affected: Documentation.