Segment or Metrics page show error when editing owners.
Incident Report for Split
Resolved
This incident has been resolved.
Posted Apr 24, 2023 - 14:58 PDT
Identified
We have identified the cause of the issue and are taking steps to remediate. As of now, the impact is minor.
Posted Apr 24, 2023 - 13:32 PDT
This incident affected: Web Console.