DNSSEC protocol rollout
Incident Report for Split
Resolved
Since no impact was found we will close this notification.
Posted Mar 23, 2023 - 14:18 PDT
Update
Forwarding to Twitter
Posted Feb 07, 2023 - 13:26 PST
Monitoring
Split will start rolling out the DNSSEC protocol this Monday 13th of February in order to increase our security posture. More information here: https://www.cloudflare.com/dns/dnssec/how-dnssec-works/

If you have reasons to believe that your devices don’t support DS responses of more than 512 bytes, please contact support@split.io.
Posted Feb 07, 2023 - 13:24 PST