SSO Update May Impact Logins
Incident Report for Split
Resolved
The update to the new SSO system is live and without incident.
Posted Apr 30, 2021 - 13:24 PDT
Monitoring
Split has updated its SAML login process. If you are having an issue logging in through SSO that likely means your team needs to update the settings in your identity provider. Please contact us at support@split.io if you are having an issue logging in.

Split provides the option to log in at https://app.split.io/ with a username and password instead of via your identity provider. If this option is enabled for your Organization you can use this method to log in until your organization updates the IdP. If you forgot your password you can ask for a password reset.

The update should take no more than ~10 minutes.
Posted Apr 12, 2021 - 07:58 PDT