Impressions traffic spike
Incident Report for Split
Resolved
We are closing this incident. We’ve left it open to monitor for further occurrences since it has been sporadic and ephemeral in nature. The issue was observed six times since the initial incident, each lasting between 1 and 9 minutes as shown below.

During the traffic spikes it’s possible there was some data loss. Because error statuses are handled by the SDK and the data is resent later, there should be little to no data loss for server-side SDKs, while JavaScript SDKs would be prone to lose more data due to customer abandonment before impressions are sent.

We have added more metrics and information to our systems to better monitor for this issue to catch the problem sooner and prevent it from having any impact.

2/22 18:52 - 18:54 UTC
2/23 15:50 - 15:51 UTC
2/23 16:00 - 16:09 UTC
2/24 18:08 - 18:12 UTC
3/1 21:38 - 21:40 UTC
3/2 20:56 - 20:59 UTC
Posted Mar 04, 2022 - 15:54 PST
Monitoring
Since 18:13 UTC the system has been operational and we are looking into the root cause of the spike. We will continue to monitor.
Posted Feb 24, 2022 - 15:26 PST
Investigating
We are currently investigating an unusual spike in traffic causing 500 errors from our impressions endpoint, for Feb-24-2022 from 18:08 - 18:13 UTC.
While most of our SDKs are designed to retry on failed requests to prevent data loss, there is a potential loss with a 5 minute window of the spike.
Posted Feb 24, 2022 - 10:59 PST
This incident affected: SDK API.